Why is the "steam only" option disabled after I uploaded a design?

I have uploaded a small sample to test. The file is in STL format. All seems good, except that the “steam only” model is disabled. What are the prerequisites to have “steam only” enabled?

It may have something to do with this:

Thank you very much! They should’ve removed the option from UI instead of gray it out to reduce confusions.