Back To Pinshape   |   Blog   |   Contests

Adding videos to the Gallery


#1

Hi there
I couldn’t add a video to the gallery. I made a link instead (see https://pinshape.com/items/6784-3d-printed-guitar-clip-notes)
Is there a way to add videos, or is this a feature that could be added?


#2

As of right now, adding a link is the best way to handle it, yeah. I agree this makes a lot of sense to add and it’s something we’ve talked about internally previosuly. It will happen for sure, just a matter of priority.

Thanks for the suggestion Morena, keep them coming!

Nick


#3

i try to add animated GIF (a timelapse) to the picture section of some of my model, but it work only 1 time on 20 try… perhaps a limit of picture weight ?


#4

When you tried to add a .GIF and it didn’t work, was there an error message shown or anything? How big is the file? .GIFs should work, so if they aren’t we will have to look into it.


#5

the gif i try to upload goes from 2mo to 11Mo, from 320x240 to 800x600. they upload right, the blue processing goes to the right, then stay here for a while (rescaling ?) then the GIF disappear from the ‘My photo’ Window,and the processing message stay blocked to the righ with nothing happen since this moment…

if you save, the gif is not here

no message of error at any stage

i even tested with different GIF construction profil (32 to 256 color, fix of adaptive palette, with or without transparent background…)

EDIT : same result with firefox 38.0.5 and IE 11.0.20

EDIT 2 : same result with the brand new firefox 39


#6

Ok, this is helpful info. We are running into some server memory issues still that the team is currently hard at work on that is likely the cause of this. Hopefully it will be fixed next week.


#7

i try this monday to add a GIF and i got this message :confused:

Failed to manipulate with MiniMagick, maybe it is
not an image? Original Error: identify /home/pinshape/webapp/releases/20150703000055/tmp/1436219008-466-0488/pin/timelapse.gif
failed with error:
identify: improper image header
`/home/pinshape/webapp/releases/20150703000055/tmp/1436219008-466-0488/pin/timelapse.gif’
@ error/gif.c/ReadGIFImage/1029

i try again with a smaller GIF and this time, i got :confused:

Failed to manipulate with MiniMagick, maybe it is
not an image? Original Error: identify /home/pinshape/webapp/releases/20150703000055/tmp/1436219207-475-7916/medium/timelapseF2.gif
failed with error:
identify: negative or zero image size
`/home/pinshape/webapp/releases/20150703000055/tmp/1436219207-475-7916/medium/timelapseF2.gif’
@ error/gif.c/ReadGIFImage/1346.

this two files are perfect legacy GIF (first one : 320x240x8bit 11.5 Mo, second : 384x288x8bit 2.79 Mo )

edit: seem that the errors are gone, but we are back at the start…


#8

end of the week :stuck_out_tongue_winking_eye: the animated gif are like the Balrog : ’ you shall not pass (still) ’ :stuck_out_tongue:


#9

So the good news is that we’ve identified and fixed some major server issues that should help overall performance. The bad news is it looks like that wasn’t the problem with the .Gifs and we’ll have to look into that separately. I’ll let you know when you’re good to go!


#10

Can you provide GIF files you were trying to upload? It would be helpful to have them while debugging. My email is (sergey AT pinshape.com). Thanks for your help!


#11

email sended :smiley:


#12

Email received. Thanks :smiley:


#13

Time for an update on this. It turns out it is a simple explanation, with a very complex solution.

Basically, there is a 100 second timeout on any file upload. If it takes longer than that to upload a file, it isn’t going to work, and because of the variability of upload speeds, we can’t specify a file size limit that will for sure work every time. To fix the issue requires a lot of re-architecting of our system. This will be done in time, but probably not too soon.

In the mean time, we suggest making your uploaded files as small as you can.

Sorry it’s not a more helpful solution at this point.

Nick


#14

strange… i try to upload a 2mo gif… it took a lot LESS than 100s (5s ? ) …even my 30Mo gif took less than 20s to upload…


#15

Thanks for the additional info, I’ll pass it along to our team.